Issue Details (XML | Word | Printable)

Key: DNET-911
Type: Bug Bug
Status: Closed Closed
Resolution: Incomplete
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Yuriy
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
.NET Data provider

No message for error code 335544528 found

Created: 28/Oct/19 08:17 AM   Updated: 02/Dec/19 04:34 PM
Component/s: None
Affects Version/s: 7.1.1.0
Fix Version/s: None

File Attachments: None
Image Attachments:

1. image.png
(180 kB)

2. image.png
(180 kB)
Environment: Windows 10 IIS ASP.NET MVC5 application


 Description  « Hide
I logged in to system using Firebird.SQL.Client and everythin was OK, but suddenly I got this exception:
 Stack trace:
[IscException: database
No message for error code 335544528 found]
FirebirdSql.Data.Client.Native.FesServiceManager.ProcessSatatusVector(IntPtr[] statusVector) +105
FirebirdSql.Data.Client.Native.FesServiceManager.Attach(...) +184
FirebirdSql.Data.Client.Native.FesServiceManager.Open() +253

[FbException (0x140000d0): database
No message for error code 335544528 found]
FirebirdSql.Data.Services.FbService.Open() +602
FirebirdSql.Data.Services.FbService.QueryService(..)
FirebirdSql.Data.Services.FbService.ProcessQuery(..)
FirebirdSql.Data.Services.FbService.Query(..)
FirebirdSql.Data.Services.FbServerProperties.GetInfo(..)
FirebirdSql.Data.Services.FbServerProperties.GetString(...)
EntityFramework.Firebird.FbProviderServices.GetDbProviderManifestToken()

[InvalidOperationException: Could not retrive storage version.]
EntityFramework.Firebird.FbProviderServices.GetProviderManifestToken(DbConnection connection)
System.Data.Entity.Core.Common.DbProviderServices.GetProviderManifestToken(DbConnection connection)

[ProviderIncompatibleException: The provider did not return a Provider ManifestToken string]
...

[ProviderIncompatibleException: An error occured accessing the database. This usually mean that the connection to database failed. Check that the connection string is correct..]

This stack trace was retyped from image so can have any errors. Original image with stack trace attached

I did not see such issues on 6.6.0.0

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Yuriy added a comment - 28/Oct/19 08:33 AM
Stack trace image

Mark Rotteveel added a comment - 28/Oct/19 10:56 AM
Error 335544528 is "database <name> shutdown"

Jiri Cincura added a comment - 28/Oct/19 06:44 PM
As Mark said, that's message when database is shutdown. There's nothing related to this on provider side. You should bring your database online and it will be good.

Yuriy added a comment - 29/Oct/19 03:16 PM
We use Firebird.Embedded v3.0.0.32485 and database should be always online.

Jiri Cincura added a comment - 29/Oct/19 06:08 PM
Apparently somebody or something did the shutdown.

Yuriy added a comment - 30/Oct/19 05:45 PM
As I understand, one of possible reasons - IIS Idle Timeout, which could shutdown IIS after 20 minutes of idle. But it have to get back running again after the first web request. Since there are no any code which manages DB shutdown, seems like embedded database still doesn't handle the stop of website by timeout.

Jiri Cincura added a comment - 31/Oct/19 07:30 AM
It's not about app pool on IIS idle/shutdown. The database itself can be put into shutdown mode, i.e. using gfix https://firebirdsql.org/rlsnotesh/util-gfix.html. It can be done programmatically from FirebirdClient too. So maybe you have some piece of code that did that.

Yuriy added a comment - 19/Nov/19 10:04 AM
We don't use such low level utils for controlling FB server except packages from Nuget, but anyway such shutdowns sometime occurs. The reason is that we use Firebird emmbedded on production in serious project and don`t want our clients face such problems.

Jiri Cincura added a comment - 19/Nov/19 02:29 PM
This functionality is present in the NuGet package of FirebirdClient. But. If you can create a reproducible test case, I can have a look. Without it, there's not much I can do.

Jiri Cincura added a comment - 02/Dec/19 04:34 PM
Closing this for now. Could be reopened when some reproducible stuff is provided.