Issue Details (XML | Word | Printable)

Key: DOC-100
Type: Bug Bug
Status: Open Open
Priority: Minor Minor
Assignee: Helen Borrie
Reporter: Peter Vandel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Documentation

Fb3 Beta1 RlsNotes - 8 Dec 2014 - v.0300-17, page 91: the setup-description assumes security3.fdb contains sysdba account

Created: 23/Dec/14 04:50 PM   Updated: 12/Mar/15 02:06 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Environment: n/a


 Description  « Hide
*** Solved in new Document version v.0300-18 ***
As long as security3.fdb contains no users, the user sysdba need to be added to it, prior to enable gsec (and isql) to modify the sysdba password. Either security3.fdb should be shipped containing user sysdba or the text in the release notes needs to be corrected.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Peter Vandel added a comment - 24/Dec/14 03:56 PM
Applies to "Firebird-3.0.0.31374-0_Win32_Beta1.zip", where security3.fdb is empty.
Windows Installer may fill security3.fdb with a sysdba account.

Peter Vandel added a comment - 03/Jan/15 04:10 PM
As a last comment, gsec is mentioned three times as deprecated in this same Release Notes document. May be better to add an ISQL-example instead.

Helen Borrie added a comment - 04/Jan/15 09:34 AM
1. Please describe how the instructions on P. 91 are not working for you. You need to be looking at the version from 8 December 2014 - Document v.0300-18

2. If you want something improved in the engine, filing a DOC ticket is not the way to register it, as nobody but the documenters will see it..

3. "Deprecated" means the feature will not be developed further and, in some future release (not this one) is likely to be removed. Essentially, gsec continues to work as before with the default security database. It does not work with alternative security databases.

Peter Vandel added a comment - 05/Jan/15 03:27 PM
What a coincidence: Two Fb3.0B1 Release Notes with the same date (8 December 2014): Document v.0300-17 and Document v.0300-18.
Page 91 of v.0300-17 incorrectly contains a modifiy command.
Page 91 of v.0300-18 correctly contains an add command.
Issue solved.