Issue Details (XML | Word | Printable)

Key: JDBC-124
Type: Bug Bug
Status: Resolved Resolved
Resolution: Cannot Reproduce
Priority: Minor Minor
Assignee: Roman Rokytskyy
Reporter: Sebastian Trebaczkiewicz
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JDBC Driver

An issue with Timestamp

Created: 04/Aug/08 10:06 AM   Updated: 06/May/12 07:32 AM
Component/s: JDBC driver
Affects Version/s: Jaybird 2.1.5
Fix Version/s: None

Environment:
FC 2.16
JDK 1.5
Firebird 2.0


 Description  « Hide
I have very strange problem when passing Timestamps to the Firebird system.

I am calling procedure which searches for records based on the Timestamps range.

When I call it with the date that is in this year
Timestamp like 2008-04-03 11:00:00.514
2008-09-03 11:00:00.517
then it works

As soon as I will setup date to be in the past (in example)
2003-04-03 11:00:00.514
2008-09-03 11:00:00.517

It throws following exception




org.firebirdsql.jdbc.FBSQLException: GDS Exception. 335544321. arithmetic exception, numeric overflow, or string truncation
No message for code 335544842 found.
null

at org.firebirdsql.jdbc.FBCachedFetcher.<init>(FBCachedFetcher.java:126)
at org.firebirdsql.jdbc.FBResultSet.<init>(FBResultSet.java:113)
at org.firebirdsql.jdbc.AbstractStatement.getCachedResultSet(AbstractStatement.java:568)
at org.firebirdsql.jdbc.AbstractCallableStatement.cacheResultSet(AbstractCallableStatement.java:964)
at org.firebirdsql.jdbc.AbstractCallableStatement.executeQuery(AbstractCallableStatement.java:257)





 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Roman Rokytskyy added a comment - 04/Aug/08 11:11 AM
Please prepare a reproducable test case. The code that handled the timestamps is the same for all of them, therefore a test case is essential.

Roman Rokytskyy added a comment - 04/Aug/08 11:14 AM
Not yet reproduced issues cannot be classified as critical. In general please use the tracker for reproducable test cases, which should be attached to the ticket.

Mark Rotteveel added a comment - 06/May/12 07:32 AM
Unable to reproduce this issue. Ticket can be reopened when a reproduction case is made available.