Issue Details (XML | Word | Printable)

Key: JDBC-258
Type: Bug Bug
Status: Resolved Resolved
Resolution: Won't Fix
Priority: Critical Critical
Assignee: Mark Rotteveel
Reporter: yue
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Jaybird JDBC Driver

jdbc driver Ignore sql as Statement

Created: 16/Jul/12 06:58 AM   Updated: 19/Jul/12 05:06 PM
Component/s: JDBC driver
Affects Version/s: Jaybird 2.2
Fix Version/s: None

Issue Links:
Relate
 


 Description  « Hide
"select count(*) as aa from table1" or "select count(*) aa from table1" in jaybird 2.1 is ok,The resultset has ColumnName "AA",
In 2.2 ,there no Column



 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 19/Jul/12 05:04 PM - edited
This is a result of the changes to the behavior of getColumnName and getColumnLabel, listed under 'Other fixes and changes' in the releasenotes. See also JDBC-162. The new behavior is as specified in the JDBC specification.

For your intended use you should use getColumnLabel() instead.

Mark Rotteveel added a comment - 19/Jul/12 05:06 PM
Closing as won't fix, as this is the intended behavior.