Issue Details (XML | Word | Printable)

Key: JDBC-281
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

copyCharacterStream passes initial position 0, instead of 1

Created: 03/Nov/12 12:36 PM   Updated: 21/Feb/13 08:08 PM
Component/s: JDBC driver
Affects Version/s: Jaybird 2.1.6, Jaybird 2.2, Jaybird 2.2.1
Fix Version/s: Jaybird 2.2.2, Jaybird 3.0

Time Tracking:
Not Specified


 Description  « Hide
copyCharacterStream passes initial position 0, instead of 1 this causes the exception below. This is triggered when setClob is called with a reader or a non-Jaybird Clob.

Caused by: org.firebirdsql.jdbc.FBSQLException: You can't start before the beginning of the blob
at org.firebirdsql.jdbc.FBBlob.setBinaryStream(FBBlob.java:511) ~[jaybird-full-2.2.1.jar:2.2.1JDK_1.7 (build: SVNTag=Jaybird_2_2_1 date=201209301312)]
at org.firebirdsql.jdbc.FBClob.setCharacterStream(FBClob.java:285) ~[jaybird-full-2.2.1.jar:2.2.1JDK_1.7 (build: SVNTag=Jaybird_2_2_1 date=201209301312)]
at org.firebirdsql.jdbc.FBClob.copyCharacterStream(FBClob.java:317) ~[jaybird-full-2.2.1.jar:2.2.1JDK_1.7 (build: SVNTag=Jaybird_2_2_1 date=201209301312)]
at org.firebirdsql.jdbc.AbstractPreparedStatement.setClob(AbstractPreparedStatement.java:1094) ~[jaybird-full-2.2.1.jar:2.2.1JDK_1.7 (build: SVNTag=Jaybird_2_2_1 date=201209301312)]

Reproduced when trying to run XWiki with modified hbm files. Clob requires additional test coverage.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 03/Nov/12 04:51 PM
Fix committed to trunk and 2.2 branch.