Issue Details (XML | Word | Printable)

Key: JDBC-309
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

JDBC 4 minor version decision uses wrong system property

Created: 27/Apr/13 03:53 PM   Updated: 11/May/13 03:13 PM
Component/s: JDBC driver
Affects Version/s: Jaybird 2.2, Jaybird 2.2.1, Jaybird 2.2.2
Fix Version/s: Jaybird 2.2.3, Jaybird 3.0

Time Tracking:
Not Specified


 Description  « Hide
The FBDatabaseMetaData.getJdbcMinorVersion() method uses java.implementation.version to decide on the JDBC minor version (4.0 <> 4.1), this is the wrong property, it should be java.specification.version.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 27/Apr/13 04:29 PM
Changed in 2.2.3 and 2.3