Issue Details (XML | Word | Printable)

Key: JDBC-374
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Blocker Blocker
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

Firebird 2.1.7 crashes when running Jaybird 3.0 tests

Created: 30/Nov/14 12:14 PM   Updated: 30/Jan/16 01:42 PM
Component/s: None
Affects Version/s: Jaybird 3.0.0
Fix Version/s: Jaybird 3.0.0


 Description  « Hide
Firebird 2.1.7 crashes when running Jaybird 3.0 tests. Investigate cause.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 30/Nov/14 12:21 PM
Looks like problem might be related to running protocol V12 tests

Mark Rotteveel added a comment - 30/Nov/14 12:33 PM
Exclude version12 tests, crash still occurs. It crashes in TestBackupManager during testRestoreReadOnly, but running that test independently works just fine.

Mark Rotteveel added a comment - 29/Aug/15 12:11 PM
Crashes seem unrelated to the tests. I also get crashes of Firebird 2.1.7 after starting and connecting with flamerobin.

Mark Rotteveel added a comment - 09/Dec/15 01:14 PM
Running the JNA tests against Firebird 2.1.7 + fbclient 2.1.7 with Flamerobin connected to the server prevents the crash, but a lot of tests still fail. Against 2.1.7 + fbclient 2.5.5 only a few tests fail (possibly using new service features). Looks like it might actually be a problem with the client library.

Mark Rotteveel added a comment - 08/Jan/16 10:22 AM
Excluded the JNA tests, uninstalled fbclient.dll from machine, tests still make Firebird 2.1.7 crash at random; I can't discount the possibility that this is a Windows 10 (and previously Windows 8) incompatibility of Firebird 2.1.7.

Mark Rotteveel added a comment - 16/Jan/16 03:43 PM - edited
Problem was caused by not reading the response to op_detach. Adding a read of those responses (and the responses to op_service_detach) fixed the crash. There are still some tests failing against 2.1.7 that require further investigation.

Commit: https://github.com/FirebirdSQL/jaybird/commit/65fc8b18b6ccdc6905b4872eb1166f58a710fb99