Issue Details (XML | Word | Printable)

Key: JDBC-428
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Trivial Trivial
Assignee: Mark Rotteveel
Reporter: John Kilin
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

No message for code 335545106 found.

Created: 07/Apr/16 11:05 AM   Updated: 20/Aug/16 01:13 PM
Component/s: JDBC driver
Affects Version/s: None
Fix Version/s: Jaybird 2.2.11, Jaybird 3.0.0


 Description  « Hide
When I try FireBird 3 via JayBird 2.2.10 i receive error:
Internal Exception: java.sql.SQLException: Cannot create PoolableConnectionFactory (GDS Exception. 335545106. No message for code 335545106 found.)

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 07/Apr/16 12:48 PM
335545106 Seems to be a (relatively) recent error message in Firebird 3 (it must have been added after the 9th of December when I last updated the messages). I will update the error message file with the next release.

Could you please post the entire stacktrace?

Mark Rotteveel added a comment - 07/Apr/16 12:53 PM - edited
The error message for 335545106 is "Error occurred during login, please check server firebird.log for details". Have you followed the instructions for using Jaybird 2.2.x with Firebird 3 on https://github.com/FirebirdSQL/jaybird/wiki/Jaybird-and-Firebird-3.0-beta-2? Because you can only login with users that have been created for legacy authentication; the new Srp authentication is not supported in 2.2.

Otherwise also post the firebird.log around the time of this error.

John Kilin added a comment - 07/Apr/16 01:18 PM
Caused by: org.firebirdsql.jdbc.FBSQLException: GDS Exception. 335545106. No message for code 335545106 found.
        at org.firebirdsql.jdbc.FBDataSource.getConnection(FBDataSource.java:120)
        at org.firebirdsql.jdbc.AbstractDriver.connect(AbstractDriver.java:138)
        at org.apache.tomcat.dbcp.dbcp2.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:38)
        at org.apache.tomcat.dbcp.dbcp2.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:255)
        at org.apache.tomcat.dbcp.pool2.impl.GenericObjectPool.create(GenericObjectPool.java:867)
        at org.apache.tomcat.dbcp.pool2.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:432)
        at org.apache.tomcat.dbcp.pool2.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:360)
        at org.apache.tomcat.dbcp.dbcp2.PoolingDataSource.getConnection(PoolingDataSource.java:133)
        at org.apache.tomcat.dbcp.dbcp2.BasicDataSource.getConnection(BasicDataSource.java:1532)
        at org.eclipse.persistence.sessions.JNDIConnector.connect(JNDIConnector.java:135)
        ... 89 more
Caused by: org.firebirdsql.gds.GDSException: No message for code 335545106 found.
        at org.firebirdsql.gds.impl.wire.AbstractJavaGDSImpl.readStatusVector(AbstractJavaGDSImpl.java:2092)
        at org.firebirdsql.gds.impl.wire.AbstractJavaGDSImpl.receiveResponse(AbstractJavaGDSImpl.java:2042)
        at org.firebirdsql.gds.impl.wire.AbstractJavaGDSImpl.internalAttachDatabase(AbstractJavaGDSImpl.java:457)
        at org.firebirdsql.gds.impl.wire.AbstractJavaGDSImpl.iscAttachDatabase(AbstractJavaGDSImpl.java:411)
        at org.firebirdsql.jca.FBManagedConnection.<init>(FBManagedConnection.java:105)
        at org.firebirdsql.jca.FBManagedConnectionFactory.createManagedConnection(FBManagedConnectionFactory.java:509)
        at org.firebirdsql.jca.FBStandAloneConnectionManager.allocateConnection(FBStandAloneConnectionManager.java:65)
        at org.firebirdsql.jdbc.FBDataSource.getConnection(FBDataSource.java:118)
        ... 98 more

John Kilin added a comment - 08/Apr/16 06:09 AM
Problem only in absence of the new error message in JayBird.
With FB everything is OK.

Mark Rotteveel added a comment - 08/Apr/16 08:12 AM
John, just to confirm: your only concern is the fact that the error message is missing?

So if I add this error message in Jaybird 2.2.11, then everything is ok?

John Kilin added a comment - 08/Apr/16 08:21 AM
Yes :)

Mark Rotteveel added a comment - 18/Jul/16 09:19 AM
Updated messages with current head of Firebird branch B3_0_Release