Issue Details (XML | Word | Printable)

Key: JDBC-446
Type: New Feature New Feature
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

Deny connection with no character set specified by default

Created: 26/Jul/16 12:30 PM   Updated: Yesterday 12:52 PM
Component/s: JCA layer, JDBC driver
Affects Version/s: None
Fix Version/s: Jaybird 3.0.0

Issue Links:
Relate
 
Replace
 


 Description  « Hide
When a user did not specify a connection character set using lc_ctype/encoding or charSet, we should deny connection by default. If a user wants to use character set NONE as the connection character set, it will need to be specified explicitly.

For backwards compatibility, add a system property, org.firebirdsql.jdbc.defaultConnectionEncoding (with the Firebird character set name) that overrides this behavior.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
William L Thomson Jr added a comment - 22/Nov/16 08:23 PM
I am having lots of issues using this new feature. I cannot seem to pass the proper character set. I am doing this in tomcat, and have been using Jaybird with Commons DBCP. I have tried all sorts of things, even setting -Dorg.firebirdsql.jdbc.defaultConnectionEncoding globally, and adding charSet onto URLs. I either end up with the connection being denied. Other times nothing happens. Then other times I get bad username and/or password. I am working with existing, works just fine with 2.x. I am trying to set the character set but it does not seem to work anywhere I have tried. The release notes are VERY vague, mentioning several variables but not where they are set, order, which to use, etc.

I really do not understand why connections need to be denied rather than fall to old behavior. Why anything has to be set to revert to old. Which the old behavior even does not seem to work. I have not had any working combination yet, and have wasted an hour or so. I just ended up going back to 2.x.

Mark Rotteveel added a comment - 24/Nov/16 10:26 AM
William, I tried to send you an e-mail but it got bounced by your mailserver. Can you contact me at mark (at) lawinegevaar (dot) nl

Mark Rotteveel added a comment - 03/Jan/17 11:25 AM
I have closed this ticket again, if you are having problems with this change, then please create a new issue with all relevant details, or send an email to the Firebird-java mailinglist if you want to discuss this.