Issue Details (XML | Word | Printable)

Key: JDBC-474
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

CONCUR_UPDATABLE Statement throws ClassCastException executing non-updatable statement

Created: 19/Jan/17 08:15 PM   Updated: 05/Mar/17 01:00 PM
Component/s: JDBC driver
Affects Version/s: Jaybird 3.0.0-beta-2
Fix Version/s: Jaybird 3.0.0-beta-3, Jaybird 3.0.0


 Description  « Hide
A Statement created with CONCUR_UPDATABLE throws a ClassCastException "Cannot cast java.sql.SQLException to java.sql.SQLWarning" when executed with a non-updatable select (ie a select referencing multiple tables).

The problem is that a warning is created as an SQLException instead.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 19/Jan/17 09:09 PM
Fix committed, test added