Issue Details (XML | Word | Printable)

Key: JDBC-509
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Fixed
Priority: Minor Minor
Assignee: Mark Rotteveel
Reporter: Artyom Smirnov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

Update JNA to 5.3 (was: Update JNA to 4.5/5.2)

Created: 18/Sep/17 12:45 PM   Updated: 27/Apr/19 12:42 PM
Component/s: JNI/JNA layer
Affects Version/s: Jaybird 3.0.3, Jaybird 4
Fix Version/s: Jaybird 4

Issue Links:
Relate
 


 Description  « Hide
In JNA 4.4 native libraries required glibc 2.14 which restrict running on older distributives, but in JNA 4.5 native libraries were recompiled with glibc 2.7.

https://github.com/java-native-access/jna/blob/master/CHANGES.md#release-450

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 19/Sep/17 10:22 AM
I haven't tested it yet, but scanning the release notes, it should not be a problem to upgrade it yourself as a workaround.

Mark Rotteveel added a comment - 27/Oct/18 12:03 PM
Update to latest JNA available before Jaybird 4 beta

Julien Nabet added a comment - 05/Feb/19 08:21 PM
I submitted a pull request here:
https://github.com/FirebirdSQL/jaybird/pull/21

Mark Rotteveel added a comment - 09/Feb/19 03:47 PM - edited
Merge request was merged to update to JNA 5.2, see JDBC-575 for a problem that surfaced as a result (although it is unlikely the problem is directly related to the JNA update).

This ticket is kept open with the intent to upgrade if a newer version is released before Jaybird 4 release.

Julien Nabet added a comment - 09/Feb/19 03:49 PM
The pull request has been merged.

Now, as I said in the comments of pull request, I don't know at all the glibc used here.

Artyom: could you give a new try when a beta including the patch would be released?

Meanwhile, considering the title of this tracker, we should be able to close this one.

Julien Nabet added a comment - 09/Feb/19 03:53 PM
Sorry Mark, I had missed your comment.
Let's keep this tracker opened then.

Mark Rotteveel added a comment - 09/Feb/19 03:57 PM
My intent is to keep this ticket open for now.

As far as the glibc related issues, nothing in the JNA release notes suggests that they have upgraded again. Given I didn't switch from Native.loadLibrary to Native.load, people who run into issues should be able downgrade to a suitable 4.x version if it is really necessary.

Mark Rotteveel added a comment - 27/Apr/19 12:42 PM
Upgraded to 5.3. Unless important issues arise, JNA 5.3.0 will be the version for all Jaybird 4 versions.