Issue Details (XML | Word | Printable)

Key: JDBC-575
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Blocker Blocker
Assignee: Mark Rotteveel
Reporter: Mark Rotteveel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Jaybird JCA/JDBC Driver

FBConnectionTest.testLockTable hangs on EMBEDDED after upgrading to JNA 5.2

Created: 09/Feb/19 03:32 PM   Updated: 20/Apr/19 09:32 AM
Component/s: JDBC driver, JNI/JNA layer
Affects Version/s: Jaybird 4
Fix Version/s: Jaybird 4

Issue Links:
Relate
 


 Description  « Hide
After upgrading to JNA 5.2.0, running FBConnectionTest.testLockTable on EMBEDDED hangs the Java process on exit. This suggests that the connection was not properly closed or some other resource was kept around. The problem only seems to be reproducible on Java 7 and 8, or on Java 11 when compiled on Java 8.

As a temporary workaround a call to fb_shutdown was added to this test class in an @AfterClass method, but that is hardly a proper solution. This needs to be investigated further if things are not properly closed or released, or otherwise a more robust cleanup is necessary. See also some of the comments on https://github.com/FirebirdSQL/jaybird/pull/21.

This is also possibly related to JDBC-519.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 20/Apr/19 09:32 AM
Problem was fixed after implementing JDBC-519