Issue Details (XML | Word | Printable)

Key: ODBC-119
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Potapchenko
Reporter: Roberto Carlos da Silva
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
ODBC Driver

When saving data type text in a field of type blob subtype 1, the information is being saved in binary form.

Created: 07/Apr/11 06:23 PM   Updated: 31/May/12 03:29 PM
Component/s: None
Affects Version/s: 2.0 Beta, 2.0 RC1, 2.0 RC2 , 2.0
Fix Version/s: 2.0.1

File Attachments: 1. Zip Archive files_for_tests.zip (125 kB)
2. File Firebird_ODBC_2.0.1.152_Win32.exe (967 kB)
3. File Firebird_ODBC_2.0.1.152_x64.exe (1.47 MB)
4. Zip Archive TestBlobFields.zip (17 kB)
5. Zip Archive TestThreadSafe.zip (444 kB)

Environment: windows 7, firebird 2.1, ODBC 2.0,
Issue Links:
Duplicate
 


 Description  « Hide
When saving data type text in a field of type blob subtype 1, the information is being saved in binary form.

with odbc driver Firebird_ODBC_1.2.0.69-Win32.exe it's work fine, but with new version Firebird_ODBC_2.0.0.151_Win32.exe, don't work


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Roberto Carlos da Silva added a comment - 07/Apr/11 06:25 PM
I send a project for you reproduce the behavior

thanks

Roberto Carlos da Silva made changes - 07/Apr/11 06:25 PM
Field Original Value New Value
Attachment TestBlobFields.zip [ 11943 ]
Roberto Carlos da Silva made changes - 08/Apr/11 05:46 PM
Security Developers [ 10012 ]
Alexander Potapchenko made changes - 08/Apr/11 06:34 PM
Affects Version/s 2.0.1 [ 10430 ]
Affects Version/s 2.1 Beta [ 10410 ]
Priority Critical [ 2 ] Major [ 3 ]
Alexander Potapchenko added a comment - 04/Jun/11 07:59 AM
The attached driver for testing

Alexander Potapchenko made changes - 04/Jun/11 07:59 AM
Attachment OdbcFb.zip [ 11961 ]
Alexander Potapchenko made changes - 11/Jun/11 08:38 AM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 2.0.1 [ 10430 ]
Resolution Fixed [ 1 ]
Alexander Potapchenko made changes - 11/Jun/11 08:49 AM
Link This issue duplicates ODBC-110 [ ODBC-110 ]
Roberto Carlos da Silva added a comment - 30/Jun/11 05:21 PM
I tested the drive attached and now work fine!! thanks. You will publish new realease for download?

Alexander Potapchenko added a comment - 30/Jun/11 05:35 PM
>>You will publish new realease for download?
After 2.0.1 release only.

Alexander Potapchenko made changes - 14/Dec/11 04:29 PM
Attachment Firebird_ODBC_2.0.1.152_x64.exe [ 12071 ]
Attachment Firebird_ODBC_2.0.1.152_Win32.exe [ 12072 ]
Roberto Carlos da Silva added a comment - 03/Jan/12 07:54 PM
Dear Alexander,
 
I installed the driver that you have attached the link http://tracker.firebirdsql.org/browse/ODBC-119,
but now is giving an error that I believe is in the implementation of the driver version: Firebird_ODBC_2.0.1.152.
I am attaching the ticket http://tracker.firebirdsql.org/browse/ODBC-119, some screens with the error,
and where the files are giving the error so you can check and correct the error.
I am also sending some links that might help you in solving the problem
 
http://dotnetdebug.net/2006/04/17/pinvoke-and-memory-related-issues/
 
http://dotnetdebug.net/category/pinvoke/
 
rename all file with extension .txt to .vb
 
thank you

Roberto Carlos da Silva made changes - 03/Jan/12 07:54 PM
Attachment files_for_tests.zip [ 12081 ]
Alexander Potapchenko added a comment - 03/Jan/12 09:32 PM
Well, is it reproduce in 2.0.0.151 version?
I need to reproduce the problem under debugger.. Can you give me full test project sources for Visual Studio?

Alexander Potapchenko made changes - 05/Jan/12 08:34 AM
Attachment OdbcFb.zip [ 11961 ]
Roberto Carlos da Silva added a comment - 31/Jan/12 01:46 PM
some errors reported:

(1) System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

(2) ERROR [08S01] [ODBC Firebird Driver][Firebird]Error reading data from the connection.

(3) ERROR [HY000] [ODBC Firebird Driver][Firebird]request synchronization error.


The read error occurs when the option is not used thread-safe.
As a suggestion, it would be nice if the thread-safe option was enabled by default in the drive.
not passing the attribute SAFETHREAD = Y in the connection string.
because in most ODBC drivers are already thread-safe without any attribute.

Roberto Carlos da Silva made changes - 31/Jan/12 01:46 PM
Attachment TestThreadSafe.zip [ 12094 ]
Alexander Potapchenko made changes - 31/May/12 03:29 PM
Status Resolved [ 5 ] Closed [ 6 ]