Issue Details (XML | Word | Printable)

Key: ODBC-129
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Potapchenko
Reporter: faridz
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
ODBC Driver

CLONE -SQLGetTypeInfo missing rows for unicode data types

Created: 02/Aug/11 11:27 AM   Updated: 31/May/12 04:54 PM
Component/s: None
Affects Version/s: 2.0 RC2
Fix Version/s: 2.0.1

File Attachments: 1. Zip Archive OdbcFb_x64.zip (1.50 MB)

Image Attachments:

1. sqlgettypeinfo.jpg
(115 kB)
Environment: Windows XP


 Description  « Hide
SQLGetTypeInfo does not return a row for any of the following supported Firebird data types:

SQL_WCHAR -> CHAR(x) CHARACTER SET UNICODE_FSS
SQL_WVARCHAR -> VARCHAR(x) CHARACTER SET UNICODE_FSS
SQL_WLONGVARCHAR -> BLOB SUB_TYPE TEXT
SQL_TINYINT -> SMALLINT



 All   Comments   Change History   Subversion Commits      Sort Order: Descending order - Click to sort in ascending order
faridz added a comment - 02/Aug/11 12:47 PM
Verified fix with attached x64 dll. Works fine now. Thanks.

Alexander Potapchenko added a comment - 02/Aug/11 12:10 PM
Yes, the problem is exists. The attached x64 driver for testing.

faridz added a comment - 02/Aug/11 11:36 AM
I now get rows for these types but funny characters for type name and local type names on x64 ansi application and success with info
Success With Info. Native Code: 0, SQLState: 01004, Return Code: 1
[ODBC Firebird Driver]Data truncated

Since driver reports the result column 'type' as size as 33

See attached screenshot