Issue Details (XML | Word | Printable)

Key: ODBC-156
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Potapchenko
Reporter: Bjoern Reimer
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
ODBC Driver

"Reserved error (-7748); there is no message for this error" with MS Access on UTF8 DBs

Created: 05/Dec/12 10:24 AM   Updated: 09/Jul/13 11:00 AM
Component/s: None
Affects Version/s: 2.0.1
Fix Version/s: 2.0.2

File Attachments: 1. Zip Archive DBUTF8.ZIP (2.97 MB)
2. File odbc-156.sql (11 kB)
3. Zip Archive OdbcFb.zip (1.16 MB)

Environment:
Firebird_ODBC_2.0.1.152_Win32.exe ODBC driver
Firebird-2.5.2.26539_0_Win32.exe client lib
MS Access 2003 or MS ACCESS 2010


 Description  « Hide
- Install InterBase ODBC driver
- Install Firebird Client Only
- Create an ODBC DataSource to the attached UTF8 character set Firebird database file using 32 Bit the "ODBC Data Source Adminstrator" tool.
- Start Microsoft Access 2003 or 2010
- Create a blank new access database
- Click on "External Data" tab and select "More" dropdown, "ODBC Database"
- In the wizard, select "Machine Data Source" (or User Data Source - depends on config) tab, and pick your ODBC data source
- Select any table (I selected TLATIN2) from the list of tables presented, and press OK

You are presented with an "Microsoft Office Access" error, and the data is not imported:
"Reserved error (-7748); there is no message for this error."

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Potapchenko added a comment - 05/Dec/12 10:39 AM - edited
Attach the database example for reproducing please. I can't reproduce this problem in MS access 2003 with my UTF-8 database.

Bjoern Reimer added a comment - 05/Dec/12 12:36 PM
Try Table DB-USER

I think it hase something to do with bigger varchar-fields

Alexander Potapchenko added a comment - 05/Dec/12 01:04 PM
I can't reproduce this problem. I have attached the database which I have created by your script. Can you reproduce the issue with my database?

Bjoern Reimer added a comment - 05/Dec/12 09:08 PM
Here is the missing part of the puzzle for reproducing the bug:

CREATE DATABASE 'LOCALHOST:D:\db\UTF82.FDB'
USER 'SYSDBA' PASSWORD 'masterkey'
PAGE_SIZE 16384
DEFAULT CHARACTER SET UTF8 COLLATION UNICODE_CI_AI;

The Collation seems to be important!

Alexander Potapchenko added a comment - 06/Dec/12 07:45 AM
The attached fixed driver for testing

Bjoern Reimer added a comment - 06/Dec/12 03:30 PM
Fix seems to work correctly

I'm testing a little bit more tomorrow!

Thank you very much!