Issue Details (XML | Word | Printable)

Key: ODBC-176
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Alexander Potapchenko
Reporter: Gregori Arjona
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
ODBC Driver

SQL_AUTOCOMMIT_ON changes to OFF after calling SET TRANSACTION

Created: 01/Oct/14 04:46 PM   Updated: 01/Jan/15 03:29 PM
Component/s: None
Affects Version/s: 2.0.2
Fix Version/s: 2.0.3

File Attachments: 1. Zip Archive Firebird ODBC.zip (396 kB)
2. File SQL_ads.LOG (23 kB)

Environment:
Server:
Windows 2003 32bits
Firebird 2.1.5 32bits

Client:
Windows 8.1 64bits
Odbc 2.0.2.153 32bits
Microsoft visual foxpro.


 Description  « Hide
By default, after opening a conection and doing some select statement, the odbc driver sets the transaction isolation mode to:

READ COMMITTED NO WAIT NO RECORD_VERSION

I checked this by query to the mon$transaction table.If a do some changes to any table the changes are commited automaticaly.

This mode is not suitable for us, because this blocks reads of changed rows by another computer. But if i change manually the transaction isolation level with the command:

SET TRANSACTION READ WRITE WAIT READ COMMITTED RECORD_VERSION

After doing this i need to commit evey change made on the database, if not commited the changes are lost after closing the connection.

I dont know whats happening but this is driving me nuts, can it be and odbc error?

Thank you.

I send to you an odbc trace file.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Gregori Arjona added a comment - 01/Oct/14 04:47 PM
ODBC SQL LOG

Alexander Potapchenko added a comment - 01/Oct/14 07:03 PM
Do you really use ODBC driver 2.0.2 (maybe there are other versions of odbc driver are exist on your computer)?
The default transaction isolation mode in 2.0.1 and later is:
READ COMMITTED WAIT RECORD_VERSION
See attached screenshots from my computer - (MON$ISOLATION_MODE (isolation mode) - 2 - read committed record version).

Gregori Arjona added a comment - 02/Oct/14 08:09 AM
Hi Alexander.

You are wright, this is version 2.0.2.153 and works as you have said, the problem is produced by machines with an older version of ODBC, exactly 2.0.0.148. I did not realize it until you told me. :-(
The mixture of multiple versions is producing problems with transactions. Now i will update the old version of all computers.

Thanks for all.

Regards.