Issue Details (XML | Word | Printable)

Key: ODBC-50
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Potapchenko
Reporter: Steven van der Wal
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
ODBC Driver

Data appears sometimes wrong in Access/Excel

Created: 21/Nov/08 10:32 AM   Updated: 02/Sep/10 06:19 PM
Component/s: None
Affects Version/s: 2.0 RC1
Fix Version/s: 2.0 RC2

File Attachments: 1. JPEG File Access.jpg (51 kB)
2. JPEG File Excel.jpg (61 kB)
3. Zip Archive OdbcFb_DLL_2-0-0149_Win32.zip (1010 kB)
4. File test.fbk (2 kB)

Environment:
Server: Firebird 2.0.4 (on Windows 2003).
Client: Windows-XP SP3, ODBC driver 2.0 RC1, Office 2003 (Access 2003), fbclient 2.0.4
Issue Links:
Relate
 


 Description  « Hide
I created a new database "c:\test.fdb", SQL dialect 3, character set none.

Create one table:
CREATE TABLE LB2_UITSLAGEN (
    BEPALINGSCODE VARCHAR(4) NOT NULL,
    BUITEN_REFERENTIE VARCHAR(1),
    UITSLAGOPMERKINGSCODE VARCHAR(4)
);

COMMIT WORK;

...and some data...
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', 'L', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', 'L', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');
INSERT INTO LB2_UITSLAGEN (BEPALINGSCODE, BUITEN_REFERENTIE, UITSLAGOPMERKINGSCODE) VALUES ('KA0D', '', '');

COMMIT WORK;

On the client I set up an ODBC connection. In Access-2003 I made a link to this table (use no unique record id).

If I open this table, Access shows the data wrong. In the second column "Buiten_referentie" appears sometimes the first letter of the first column "Bepalingscode". Strange is, that if you ORDER the table in Access (Right klik; order ascending), the data is correct. If you make a query on the table, it is the same. No ordering shows wrong data ("K" in the second column); ordering shows everting OK.

This is what you see in Access with no ordering:

BEPALINGSCODE BUITEN_REFERENTIE UITSLAGOPMERKINGSCODE
KA0D
KA0D L
KA0D
KA0D K
KA0D
KA0D K
KA0D
KA0D K
KA0D
KA0D K
KA0D L
KA0D K
KA0D K
KA0D K
KA0D K

In Excel-2003 it also goes wrong; you can see squares (non printables) in the second column...

If I use the old ODBC driver IBclient version 5.6, everthing is OK. Also the firebird ODBC-driver 1.2.0.69 works fine.

I hope this problem can be reproduced and solved. I you need more information, I will send it to you.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Steven van der Wal added a comment - 21/Nov/08 10:47 AM
Access-2003

Steven van der Wal added a comment - 21/Nov/08 10:47 AM
Excel-2003

Steven van der Wal added a comment - 21/Nov/08 10:48 AM
Test.fbk

Alexander Potapchenko added a comment - 21/Nov/08 01:45 PM
Please test this build with all your applications which use Firebird ODBC driver :=)

Alexander Potapchenko added a comment - 26/Nov/08 04:27 AM
Is your problem resolved?

Steven van der Wal added a comment - 27/Nov/08 05:02 AM
The problem is resolved using Access-2003, but still remains if I use Excel 2003 with this new build. The results in Excel 2003 are exactly the same.

Alexander Potapchenko added a comment - 27/Nov/08 10:27 AM
Well, I have found more general error, thanks and please see my new build.

Steven van der Wal added a comment - 02/Dec/08 04:50 AM
I just tested the new ODBCFB.dll and the problem is resolved for both Access-2003 and Excel-2003. Thanks a lot, Alexander!

Azul Chan added a comment - 19/Mar/09 04:54 AM
Hello all, i'm a developer using Excel to extract data from Firebird using ODBC (fbclient.dll version 2.0.3.12981).
I think i got the same problem here. Sometimes a cell is supposed to be empty, but it becomes a duplication of the previous row, with randomly placed squares or the value is randomly truncated.
I guess the "odbcfb.dll" file here could solve the problem? but how can I use it? (like how to setup in ODBC Data Source in Windows)
Thanks!

Azul Chan added a comment - 19/Mar/09 05:00 AM
one more thing, it happens when I try to extract a few hundred rows at once, and some of the values contain Chinese characters


Azul Chan added a comment - 19/Mar/09 05:26 AM
Oh, I just backed up the odbcfb32.dll in C:\windows\system32 and copied the new one there, then it works!!!
Thanks :)

Maycon Ferraca added a comment - 01/Sep/10 12:01 PM
I think I am having the same problem here, but I cannot download RC2 version because the address http://www.firebirdsql.org/downloads/snapshot_builds/odbc/ is no longer available. May someone send me the correct one?

Thanks in advance.