Issue Details (XML | Word | Printable)

Key: ODBC-81
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Andrew
Votes: 1
Watchers: 1

If you were logged in you would be able to see more operations.
ODBC Driver

DG4ODBC on Linux-64 connection fail

Created: 29/Mar/10 06:01 AM   Updated: 01/Jan/15 03:33 PM
Component/s: None
Affects Version/s: 2.0 RC1
Fix Version/s: 2.0.3

File Attachments: 1. Text File dg4odbc.log (10 kB)
2. File dg4odbc_config_files.rar (2 kB)
3. File hs_core_trace_21439.trc (115 kB)
4. Text File odbc.log (16 kB)
5. File strace_log.rar (16 kB)
6. File U53Fb4ODBC_agt_20601.trc (10 kB)
7. Text File unixODBC_trace.log (7 kB)

Environment: Ubuntu 9.04, 64-bit. ODBC Driver 2.0.148 64-bit. Oracle DG4ODBC 64-bit.

 Description  « Hide
I have a 2 servers on Ubuntu 9.04 with Oracle11r2 with same configuration. One of them with 32, and other with 64 bit architecture. For connection to firebird I use IBPhoenix ODBC driver - implementation for 32 and 64 bit. From Linux32 everything ok, but from 64 I got error ORA-28511: connection HS Agent lost. First few queries were almost succesful (error something about charcterset conversion), but now only ORA-28511:( Connection by unixODBC's isql to DSN-source is OK.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Ivan Volnikov added a comment - 28/Feb/11 02:15 PM
That problem was solved in - it is the same

Fred added a comment - 17/Nov/11 04:04 PM
This issue is not solved as stated.

I run Oracle x64 and 02.00.0151.

The driver segfault at the same location (right after "SQLGetInfo returns Y for SQL_COLUMN_ALIAS")

Stanislav Studený added a comment - 18/Dec/13 08:42 AM - edited

I'm running x86_64 Oracle, unixODBC 2.3.2 + OdbcFb-LIB- + firebird-libfbclient- and I have similar problem.
I'm able to connect using isql and issue the select command, but i'm not able to make a select from Oracle -> DG4ODBC Gateway -> unixODBC manager -> ODBC Firebird driver -> Firebird. All fails after SQLFetch.c :

                        Statement = 0x1fc8dc0

Trace from unixODBC and DG4ODBC will be uploaded.

Stanislav Studený added a comment - 18/Dec/13 08:43 AM
unixODBC 2.3.2 trace file

Stanislav Studený added a comment - 18/Dec/13 08:46 AM
x86_64 Oracle DG4ODBC tracefile

Stanislav Studený added a comment - 18/Dec/13 09:10 AM
Uploaded DG4ODBC core stacktrace hs_core_trace_21439.trc

failing call is _ZN15OdbcJdbcLibrary11OdbcConvert21convVarStringToStringEPNS_10DescRecordES2_()+308

Stanislav Studený added a comment - 18/Dec/13 12:26 PM
Driver compiled from source on RHEL 6.4, and now it works...

LDD of working library after compilation:

# ldd => (0x00007fff893e4000) => /lib64/ (0x00007f7503433000) => /lib64/ (0x00007f750322f000) => /usr/local/unixODBC/lib/ (0x00007f7503018000) => /usr/lib64/ (0x00007f7502d12000) => /lib64/ (0x00007f7502a8e000) => /lib64/ (0x00007f7502877000) => /lib64/ (0x00007f75024e4000) => /lib64/ (0x00007f7502282000)
        /lib64/ (0x00007f75039db000) => /lib64/ (0x00007f7502064000)

LDD of not working lib from :

# ldd => (0x00007fffc1b76000) => /lib64/ (0x00007ff9a90f2000) => /usr/local/unixODBC/lib/ (0x00007ff9a8eda000) => /usr/lib64/ (0x00007ff9a8bd4000) => /lib64/ (0x00007ff9a8950000) => /lib64/ (0x00007ff9a873a000) => /lib64/ (0x00007ff9a83a7000)
        /lib64/ (0x00007ff9a9618000) => /lib64/ (0x00007ff9a818a000)