Issue Details (XML | Word | Printable)

Key: PYFB-36
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Pavel Cisar
Reporter: Douglas Hammond
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird driver for Python

When using driver with Interbase V8.1.1.333 connection fails.

Created: 07/Jun/13 02:08 AM   Updated: 07/Jun/13 05:17 AM
Component/s: None
Affects Version/s: None
Fix Version/s: None


 Description  « Hide
The version check default to using isc_info_firebird_version which does not work with interbase server.

When switched to using isc_info_version instead it works,

Here is the version string I get when using isc_info_version WI-V8.1.1.333

This may be the case with other Interbase server. Perhaps this driver will not support connection to an intebase sever but only a firebird server?

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 07/Jun/13 05:17 AM
FDB does not support InterBase. It's designed to work only with Firebird v2.0 and higher.