Issue Details (XML | Word | Printable)

Key: PYFB-47
Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: Trivial Trivial
Assignee: Pavel Cisar
Reporter: Geovani de Souza
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird driver for Python

Error: The location of Firebird Client Library could not be determined.

Created: 28/Jan/15 07:28 PM   Updated: 29/Jan/15 01:41 PM
Component/s: None
Affects Version/s: 1.4.3
Fix Version/s: 1.4.4

Environment: Ubuntu 14.04 LTS


 Description  « Hide
Hello guys,

I'm trying to deploy a Django project that uses django-firebird app, that uses fdb.

I'm deploying on http://flynn.io/, an alternative to heroku, using heroku-buildpack-multi, because I need to install libfbclient2 to enable fdb.

The problem is that heroku-buildpack-apt that I use to install libfbclient2 puts the lib on "/app/.apt/usr/lib/x86_64-linux-gnu" and add this folder to LD_LIBRARY_PATH, but the class "fdb.ibase.fbclient_API" doesn't reach the fbclient lib, because "ctypes.util.find_library" is unable to read alternative folder from LD_LIBRARY_PATH, for example (http://bugs.python.org/issue2936).

Reading the source, I saw that "fdb.ibase.fbclient_API.__init__()" accepts a parameter "fb_library_name". This is passed from "fbcore.load_apit()" that is called from "fbcore.connect()" and "fbcore.create_database()", but the last two doesn't uses this parameter.

My suggestion is to add the "fb_library_name" to "fbcore.connect()" and "fbcore.create_database()" passing it to "fbcore.load_api()".

This way, I can set "settings.DATABASES['myfbdb']['OPTIONS']['fb_library_name']" on my Django project settings, that is passed through django-firebird to fb ("fbcore.connect()" to be specific).


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 29/Jan/15 09:05 AM
You're correct that this parameter should be present in connect and create_database. Change committed.

Geovani de Souza added a comment - 29/Jan/15 10:15 AM
Thank you Pavel!

Is this version published on PyPI?

Pavel Cisar added a comment - 29/Jan/15 01:41 PM
Not yet, but 1.4.4 should be released soon (early Feb).